download
the latest version
 

Version History

Minor updates are free, but customers using version 1 or 2 must pay to upgrade to version 3. For notification of new releases, follow us on Twitter!

Version 3

Version 3.3.5 (October 9, 2014)
  • Added Brazilian EPE export format.
  • Improved flag rules to handle direction ranges spanning true north.
  • Improved handling of non-Unicode language settings.
Version 3.3.4 (September 19, 2014)
  • Improved Mean by Month table to show vector mean directions.
  • Improved Monthly Statistics and Annual Statistics tables to show, for wind direction columns, the number of time steps from which the vector mean direction is calculated.
  • Improved text export from monthly and annual time series graphs.
  • Improved import of time series data exported from WindSim.
  • Eliminated risk of out-of-memory crash when saving large .windog files.
Version 3.3.3 (June 30, 2014)
  • Added Weibull Statistics by Month table to the Tables tab.
  • Fixed bug causing incorrect normalization in TAB files with seasonal bias removed in rare cases.
  • Modified delimiter detection logic to improve handling of files with many blank elements.
  • Improved import of Vortex data files.
  • Changed WindSim TWS file export to use European number format in header.
Version 3.3.2 (June 16, 2014)
  • Fixed bug causing Wind Turbine Output window to crash occasionally.
  • Improved data import logic for more reliable import of Ammonit Meteo-40 data files.
Version 3.3.1 (May 30, 2014)
  • Fixed bug preventing v3.3 windog files from distinguishing themselves from v3.2 files.
Version 3.3 (May 27, 2014)
  • Added new Append Status window and made multi-file append process more robust.
  • Enabled multiple-file import by dragging and dropping a folder into Windographer.
  • Added menu items for Open Folder and Append Folder.
  • Improved data import logic to increase robustness.
  • Improved ability to handle files containing thousands of data columns.
  • Improved detection of first and last line of data.
  • Improved time step detection when reading NSD files.
  • Improved data column type detection when reading Campbell Scientific files.
  • Allowed multiple selection of flags in Define Flags and Define Favorite Flags windows.
  • Fixed bug causing min and max direction values to escape the valid 0-360° range after applying an offset or scale factor.
Version 3.2.5 (March 31, 2014)
  • Improved detailed status messages during database import process.
  • Added target and reference concurrent mean speeds to MCP Compare Sites tab.
  • Improved data downloader’s handling of slow response from NASA webserver.
Version 3.2.4 (February 26, 2014)
  • Added number of time steps to the TAB file export module.
Version 3.2.3 (February 14, 2014)
  • Improved recognition of date/time data during raw data import.
  • Fixed bug in Data Downloader preventing it from working under a trial license.
Version 3.2.2 (January 28, 2014)
  • Fixed bug causing occasional crash after appending new data columns.
Version 3.2.1 (January 16, 2014)
  • Fixed bug causing occasional crash in Flag Manually window.
Version 3.2 (January 16, 2014)
  • Allows free download of MERRA data via Windographer Data Downloader beta.
  • Allows scaling of TAB files to a particular wind speed.
  • MCP window now allows up to twelve yearly divisions.
  • Compare Data Sets window now offers option to filter for the overlap period.
  • Now stack up to three time series graphs. Watch Video
  • Tower Distortion Analysis window now shows differences as well as ratios.
  • When re-opened, the Flag Manually window now restores the state in which you left it.
  • Made flag rules obey default flag filtering in search columns.
Version 3.1.12 (January 8, 2014)
  • Added several turbines to library, including Nordex N131/3000, Repower 6.2M152, W2E120.
  • Made database import logic more forgiving of unrecognized data column type codes.
Version 3.1.11 (November 21, 2013)
  • Fixed bug causing occasional crashes in Tables tab.
  • Changed WindFarmer WTI export to calculate the correct numbers for the Sigma Sigma table.
Version 3.1.10 (November 4, 2013)
  • Made Append window re-appear during the multi-file append process whenever column labels change.
  • Added the new Vestas V105 - 3.3 MW to the wind turbine library.
Version 3.1.9 (October 1, 2013)
  • Improved data import logic in several ways to enable it to read more file formats.
  • Made the Flag Manually table obey the decimal place settings the user enters in Tools > Options > Formatting.
Version 3.1.8 (September 3, 2013)
  • Added option to export transposed tables.
  • Added tool tips to drop-down boxes to show long strings.
  • Added up and down arrow keys as zoom shortcuts on time series graphs.
Version 3.1.7 (July 26, 2013)
  • Fixed bug causing occasional miscalculation of mean wind speed of TAB files.
  • Added subtle background colors to indicate data column type in some tables.
Version 3.1.6 (June 27, 2013)
  • Fixed bug causing Turbulence Analysis window to initialize incorrectly in some files.
  • Added occurrences, min, max, and standard deviation by month tables to Tables tab.
  • Changed append process to import all data columns, even empty ones.
Version 3.1.5 (June 20, 2013)
  • Improved the Append window to simplify the mapping of new columns to existing columns.
  • Added the ability to specify marker type in graphs (diamond, circle, triangle, X)
  • Added shortcut keys to time series graph: -/+ for zoom and arrow keys for scroll.
  • Added 24 and 36 to the allowable number of direction sector subdivisions in the MCP window.
  • Changed WindFarmer WTI file export logic to center bins on integer wind speeds.
  • Added another column to the openWind export file (for Monin-Obukhov length, currently just zeroes).
  • Improved Vortex data file import to recognize temperature and pressure columns and to set their heights correctly.
  • Allowed multi-select of flag rules in Flag With Rules and Define Favorite Flag Rules windows.
  • Fixed bug preventing favorite flags from being saved in some situations.
Version 3.1.4 (May 3, 2013)
  • Added hotkeys to speed flagging in Flag Manually and Flag by Scatter Plot windows.
  • Added mouse wheel shortcut for zooming in and out of time series graphs.
  • Added speed-versus-direction display option in MCP window.
  • Improved data import logic to ignore the checksum column in new ZephIR data files.
Version 3.1.3 (April 29, 2013)
  • Added to the Wind Rose tab the option to display total energy by direction and month.
  • Fixed bug preventing total energy by direction rose from appearing on the Wind Rose tab.
  • Made the labeling of the angular axis optional for polar graphs.
Version 3.1.2 (April 22, 2013)
  • Fixed bug in MCP window that caused a crash after import of hourly target data.
  • Fixed bug in gap fill logic causing a crash if the data column ended with a gap.
  • Fixed bug causing Wind Rose tab to crash in the absence of direction data.
Version 3.1.1 (April 18, 2013)
  • Fixed bug in MCP window that incorrectly disabled the Export Final Data Set button.
Version 3.1 (April 17, 2013)
  • Added tabular display to the Flag Manually window.
  • Added to the Flag by Scatter Plot window triangular and free-form selection options.
  • Added the ability to test flag rules before executing them.
  • Added the Inspect and Remove Flags window.
  • Added to Wind Rose tab the option to plot twelve monthly wind roses.
  • Added ‘stacked bars’ wind rose style to Wind Rose tab.
  • Added Export Image window.
  • Added to Compare Sites tab of MCP window the summary tables option, the option to show only concurrent data, and the target/reference speed ratio data column.
  • Added Fix Quantization window, which randomizes quantized data to improve the performance of extreme wind or MCP analyses.
  • Improved layout of tables in formatted reports, especially those with merged cells.
  • Improved Document History window: a double click now brings up a new window showing additional details.
  • User-defined calculated columns now calculate vector mean direction if both source data columns are directional.
  • Added coefficient of power to the power curve graph in the Wind Turbine Details window.
  • Added display variables 'net energy' and 'proportion of net energy' to Wind Turbine Output window.
  • Added 'by month of data set' display option to Wind Turbine Output window.
  • Improved TAB file export by reporting mean of time series and of TAB file, and by adding the ability to make the first bin half-sized.
  • Added ability to export Windfarmer WTI files.
  • Added the ability to export to SAM, the System Advisor Model.
  • Added option to time series export tab to skip empty lines.
  • Added to the Delete Data window the ability to delete data points not flagged with specified flags.
  • Improved import of NCDC Global Summary of the Day data files.
  • Fixed screen flicker problem in Flag by Scatter Plot window.
  • Fixed bug in gap fill process that occasionally left some gaps unfilled.
  • Fixed bug on Wind Rose tab causing by-month and by-hour results not to recalculate after a data modification.
  • Fixed bug on Wind Rose tab that caused settings and graph to get out of sync after a data modification.
  • Fixed bug in Flag Manually window where time series would forget your flag visibility settings whenever you flagged or unflagged a segment.
  • Fixed bug causing turbulence-by-speed table to appear blank in certain circumstances.
  • Fixed bug that occasionally prevented Delete Data window from resetting start or end date of data set.
  • Made all flag windows warn on cancel if it will result in lost changes.
Version 3.0.12 (March 21, 2013)
  • Added support for Excel 2013.
  • Fixed bug causing occasional crash when generating Extended Summary report.
Version 3.0.11 (February 21, 2013)
  • Improved identification of hour/minutes/seconds columns during data import process.
  • Fixed bug in NSD file import logic causing it to skip some time steps and leave gaps.
  • Fixed bug sometimes causing favorite flag rules to lose the name of the flag that they apply.
  • Fixed bug where user-created wind turbines did not appear in the MCP window.
Version 3.0.10 (January 25, 2013)
  • Changed air density calculations to account for the height of the temperature and pressure sensors.
  • Improved import of WindCollector2 data files.
  • Improved import of AQ500 data files.
  • Improved import of Campbell Scientific data files.
  • Improved import of data files with French number formatting and lots of blank elements..
  • Fixed bug causing Windographer to ignore gaps when importing NSD files.
  • Fixed bug where flag rules searching for differences between direction sensors did not account for the fact that 360° = 0°.
  • Fixed bug where user-defined calculated columns defined as the difference between two directional columns did not account for the fact that 360° = 0°.
  • Fixed bug preventing calculated data column recalculation when flag properties are changed.
  • Fixed bug preventing final column of Monthly Statistics and Annual Statistics tables from appearing.
Version 3.0.9 (November 29, 2012)
  • Made full functionality of Tower Distortion Analysis window available in Standard edition.
  • Fixed bugs in importing of NSD files.
  • Improved column identification when importing AQ500 data files.
  • Updated database interface to version 3.
Version 3.0.8 (November 19, 2012)
  • For Method of Independent Storms, changed default independence criterion from 0 to 48 hours, and changed recommended storm frequency from 100 storms/yr to 20 storms/yr.
  • Fixed bug causing crash in Tower Distortion Analysis window in Standard edition.
  • Fixed bug preventing import of some NSD files.
  • Fixed bug causing occasional crash when opening Symphonie data files.
Version 3.0.7 (November 5, 2012)
  • Added versus-hour-of-day option to Wind Rose tab, along with some additional flexibility.
  • Added a validity check to the openWind export tab to require turbulence data.
  • Fixed bugs in, and improved flexibility of, NSD file import logic.
  • Fix to bug (affecting v3.0.6 only) that caused import logic to skip a data column occasionally.
  • Improvements to data column recognition in Kintech data files.
  • Small change to data import logic to improve handling of WindSim format files.
  • Added to turbine library: Vestas V164-8.0MW, REpower 3.0M-122, Leitwind LTW77-1000.
Version 3.0.6 (October 10, 2012)
  • Added intermediate results and tabular/graphic buttons to Extreme Wind Analysis window.
  • Removed flag filtering capability from Data Recovery Analysis window to avoid confusion.
  • Added option to include latitude, longitude, and elevation in template files.
  • Adjusted data import logic to improve handling of WindSim TWS format and similar formats.
Version 3.0.5 (September 24, 2012)
  • Improved identification of data columns in when reading Pentalum SpiDAR data files.
  • Fixed bug causing import process to skip a data column occasionally.
  • Fixed bug that prevented access to Tower Distortion Analysis window in data sets containing no co-located wind speed sensors.
Version 3.0.4 (September 18, 2012)
  • Improved data import logic to improve handling of space-delimited files.
  • Improved gap fill algorithm to account for correlation between temperature sensors.
Version 3.0.3 (September 6, 2012)
  • Improved data import logic to handle column headings that span multiple lines.
Version 3.0.2 (September 4, 2012)
  • Fixed bug in import logic causing it to ignore the last time step.
  • Fixed bug in Configure Data Set window preventing the changing of coordinate systems.
Version 3.0.1 (August 30, 2012)
  • Made a small fix to ensure v3 trial license doesn't interfere with v2 permanent license
Version 3.0 (August 27, 2012)
  • A new measure-correlate-predict (MCP) module
  • A new Compare Data Sets window to compare graphically two or more data sets
  • A new Extreme Wind Analysis window that implements the Method of Independent Storms
  • A new ability to flag by scatter plot
  • A new ability to define your own calculated data columns
  • A greatly improved Wind Turbine Output window and expanded turbine library
  • Multiple temperature and pressure sensors at different heights
  • New relative humidity data column type
  • Expanded database interface to handle new data column types
  • A new Wind Speed Ratios window
  • New abilities to analyze wind veer, temperature profile, and long-term trends
  • Many new graphical and tabular outputs
  • Precise date range filtering
  • Lots of small improvements like more flexible bin settings, control of significant digits, etc.
  • New minimum data coverage requirements for averaging to longer time steps
  • More powerful and more flexible data import capability

Version 2

Version 2.4.13 (August 23, 2013)
  • Added support for Excel 2013.
Version 2.4.12 (June 20, 2013)
  • Fixed bug where flag-specific data deletion ignored date range.
Version 2.4.11 (January 16, 2013)
  • Added to Tower Distortion Analysis window the ability to analyze wind speed sensors at different heights.
  • Fixed bug causing crash when reading certain version 3 windog files.
Version 2.4.10 (October 22, 2012)
  • Made optional the flagging of vertically extrapolated wind speeds as synthetic.
  • Improved ability to recognize wind speed and direction data columns in Kintech .wnd files.
  • Made data file import logic more flexible regarding delimiters.
  • Fixed bug causing occasionally incorrect column headings in shear-by-bin table on Wind Shear Analysis window.
Version 2.4.9 (September 13, 2012)
  • Added the ability to read .windog files created by Windographer 3.0
  • Updated PDF utility to make it work with 64-bit systems
Version 2.4.8 (September 5, 2012)
  • Fixed bug that prevented Triton turbulence data from appearing in the Summary Report
  • Fixed memory leak in time series graphs
Version 2.4.7 (June 19, 2012)
  • Fixed bug causing start/middle/end-of-interval setting to apply only to first file during multiple file append process.
Version 2.4.6 (March 22, 2012)
  • Added ability to import .wt files into Append Data window via Load Settings button.
  • Added ‘Wind Speed Statistics for Synthesis’ table to Tables tab.
  • Improved reading of 3Tier data files to recognize wind speed column.
  • Improved reading of Vortex data files to recognize temperature and pressure columns.
  • Improved reading of LT-VMM data files from AWS Truepower to recognize data column types, measurement heights, latitude, longitude, and elevation.
  • Improved support for Oracle database integration.
  • Improved the handling of missing data points in the Meteodyn WT export file.
  • Fixed bug in openWind export tab.
  • Fixed bug in operation of flagged segment list on Results tab of flag windows.
  • Fixed bug with “never overwrite” append setting.
  • Fixed bug causing occasional mistakes when moving flags (and rules) to or from favorites.
  • Fixed bug causing Flag Tower Shading window to miss 0° and 360° winds.
  • Fixed bug causing occasional miscalculation of data recovery in Directional Statistics table.
  • Fixed bug causing ‘changes more than’ search criterion to work incorrectly
Version 2.4.5 (January 6, 2012)
  • Added openWind export tab.
  • Allowed symbol size change in scatter plots.
  • Reduced use of Windows number format to time series export only.
  • Fixed bug causing deletion of data from the start of the data set to be very slow.
  • Improved data import logic to facilitate import of daily data.
  • Improved logic for intelligently detecting the day/month columns in appended data files.
Version 2.4.4 (October 19, 2011)
  • Improved import logic to identify data columns more accurately in Windcube data files.
Version 2.4.3 (October 3, 2011)
  • Fixed bug in vertical extrapolation causing calculation errors when you select only a subset of the wind speed sensors.
  • Fixed bug in Export Data > Time Series causing settings to sometimes differ from those the user has requested.
  • Improved data import logic to better identify wind speed data columns in Triton data files.
  • Changed .TAB file export to use the dot decimal separator regardless of your Windows number format.

Version 2.4.2 (August 11, 2011)
  • Fixed bug preventing import of NSD files.
  • Improved identification of date/time data during file import.
  • Added support for proxy connections for users behind firewalls.
  • Improved image quality in reports.
  • Fixed flag filtering bug on the Scatter Plot tab.
  • Made the Export Data > Time Series tab save its settings.
Version 2.4.1 (July 20, 2011)
  • Fixed bug in process of appending one .windog file to another, causing flagged segments to copy across incorrectly under some circumstances.
  • Modified the process of exporting flags to the database, so that only the newly added, deleted, or modified flags get written to the database.
Version 2.4 (June 30, 2011)
  • Added database import/export capability.
  • Added to the Histogram tab the option to bin by month or by time of day.
  • Added user name to the Document History window.
  • Added computer-level licensing.
  • Fixed bug in WAsP algorithm for fitting Weibull distribution.
  • Added ability to recognize EDF-EN files, and to treat their error codes (-999, -888, -777) as blanks.
Version 2.3.2 (June 8, 2011)
  • Reduced memory requirements for the gap fill process.
Version 2.3 (May 18, 2011)
  • Improved the append process by adding the Append Data window.
  • Improved gap fill logic to account more accurately for diurnal and seasonal patterns.
  • Added option for computer-level licensing.
  • Changed export files to use the Windows number format.
  • Improved image resolution of graphs in reports.
  • Changed Meteodyn export to include lines with missing values and to use .tim extension.
  • Fixed bug in reading of lat/long from NDF files.
Version 2.2.3 (February 14, 2011)
  • Improved ZephIR data import logic.
  • Added bin size control to Wind Shear Analysis window.
  • Improved data set coverage control image export.
  • Improved memory allocation in statistics by bin and direction tables.
  • Improved File > Append logic to include flagged segments when appending a .windog file.
Version 2.2.2 (January 21, 2011)
  • Fixed minor interface bug in Flag Data Manually window.
  • Improved messages in License Management window.
Version 2.2.1 (December 21, 2010)
  • Improved reading of ZephIR data files by treating 9997, 9998, and 9999 values as gaps.
  • Fixed bug in vertical extrapolation window causing incorrect calculation if the measurement height units are feet.
Version 2.2 (December 8, 2010)
  • Added Inflow Angle Analysis window.
  • Added Data Recovery Analysis window.
  • Improved the data import logic relating to Triton, ZephIR, ASC, and Windcube data files.
  • Improved time series graph legend by adding flag checkboxes and scrollbar.
  • Made graphs remember their visible channels.
  • Fixed bug where Fill Gaps process did not ignore data flagged to be excluded from calculations.
  • Renamed Diurnal Profile table to Mean by Month and Hour of Day.
  • Renamed Seasonal Profile table to Mean by Year and Month.
  • Fixed minor problem with Windsim TWS export format.
  • Fixed bug causing Date/Time Anomalies window not to appear when it should.
  • Fixed bug causing problems when you create lots of flag rules.
  • Made version 1 Quality Control comments appear in the Document History window.
Version 2.1.2 (September 2, 2010)
  • Fixed bug causing ‘direction sectors’ drop-down box in Wind Shear Analysis window to become disabled if the data set contained only one wind direction sensor.
  • Fixed minor bug in filter-by-data-column logic.
Version 2.1.1 (August 27, 2010)
  • Fixed date bug for NDF file import.
Version 2.1 (August 23, 2010)
  • Added ability to open NDF files written by the Nomad2 data logger by Second Wind Inc.
  • Added ability to open NSD files written by the Symphonie data logger by NRG Systems.
  • Added option to not use fractional completeness factors in calculation of mean of monthly means.
  • Added option to calculate root mean square of wind speed standard deviation values when combining multiple smaller time steps into a single larger time step.
  • Changed Meteodyn export format to skip time steps that are missing speed, direction, or
    standard deviation data.
Version 2.0.4 (July 26, 2010)
  • Fixed bug in custom export format.
Version 2.0.3 (July 21, 2010)
  • Fixed column abbreviation bug in custom export format.
Version 2.0.2 (July 9, 2010)
  • Fixed bug in calculation of seasonally-adjusted tab file.
  • Fixed bug in Wind Turbine Output window that caused it to ignore flags in some cases.
  • Improved handling of scientific notation in input files.
Version 2.0.1 (June 1, 2010)
  • Added the ability to change font sizes in graphs via the Properties window.
  • Fixed bug in Histogram tab so that the Weibull c parameter units match the x-axis units.
  • Fixed bug in Wind Turbine Output window so that hub height wind speed units match those of the wind speed data columns.
Version 2.0 (April 30, 2010)
  • New data flagging and filtering capability. Watch Video
  • Improved Vertical Extrapolation module.
  • New Tower Distortion Analysis module.
  • New Short Time Interval Analysis module.
  • Improved ability to interpret Triton SoDAR data files. Watch Video
  • Improved WAsP tab file export including ability to remove seasonal bias.
  • Improved ability to import RWD files.
  • New Meteodyn export format.
  • For more information, see the document What’s New in Windographer 2?

Version 1

Version 1.52 (January 7, 2014)
  • Fixed bug preventing earlier versions from reading 2014 data files.
Version 1.51 (October 18, 2012)
  • Fixed bug in WAsP Weibull fit algorithm.
Version 1.50 (January 5, 2012)
  • Fixed bug preventing version 1.49 from reading 2012 data files.
Version 1.49 (November 18, 2010)
  • Fixed bug in Virtual Anemometer window causing incorrect calculations when extrapolating to multiple heights.
  • Added ability to import Excel files using Excel 2010.
Version 1.48 (September 8, 2010)
  • Fixed bug causing wind shear data columns to have incorrect values for time steps in which one or more wind speed sensors reported no data. This bug did not affect the Wind Shear Analysis window, the Virtual Anemometer window, or the Wind Turbine Output window.
Version 1.47 (October 23, 2009)
  • Improved reading of latitude and longitude from raw data files.
  • Added latitude and longitude to time series export files.
  • Added support for Unicode text files.
Version 1.46 (May 19, 2009)
  • Fixed bug that prevented time series graph legend from appearing when the data set contained a single data column.
  • Fixed bug that prevented time stamps from appearing in data files exported from time series graphs.
  • Fixed bug that caused occasional crashes when appending data.
  • Fixed bug that prevented the install file from installing the sample data file.
  • Fixed bug that prevented scatterplot from exporting data when a wind speed filter applied.
Version 1.45 (March 18, 2009)
  • Fixed bug that caused an out-of-memory error.
  • Fixed bug that prevented the automatic application of a template when appending data files.
Version 1.44 (March 12, 2009)
  • Fixed bug that caused the scatterplot to display erroneous data when the X and Y data columns contained dissimilar gaps.
Version 1.43 (March 10, 2009)
  • Fixed bug that disabled the File > Append button in the toolbar.
Version 1.42 (March 5, 2009)
  • Fixed bug in Configure Data Set window preventing you from changing the units of the temperature and pressure columns.
  • Fixed bug in Quality Control window preventing you from deleting the last time step.
Version 1.41 (March 2, 2009)
  • Improved the ability to recognize the date format in Excel files.
Version 1.4 (February 26, 2009)
  • Added the Reports tab, which produces formatted reports that the user can print or export to a PDF file.
  • Added the Probability of Exceedence window, which calculates the P50, P75, and P90 values.
  • Added the Frequency Distribution Analysis window, which compares three algorithms for finding the best-fit Weibull distribution.
  • Added the Time Shift window, which allows the user to apply a time shift to the entire data set, or just a particular data segment.
  • Allowed selection of multiple data columns in the Configure Data Set window.
  • Improved the Wind Shear Analysis window.
  • Improved the Extreme Wind Analysis window.
  • Added the ability to filter by direction sector in the Scatterplot tab.
  • Added the ability to filter by direction sector on the PDF tab.
  • Added best-fit Weibull lines to monthly wind speed PDF graphs.
  • Added the ability to append a .windog file using File > Append.
  • Changed IEC turbulence categorization to account for the fact that the values in IEC3 Table 1 are the upper ends of the ranges, not the centers as we had previously assumed.
  • Changed wind shear tool window to show default wind shear profile (concurrent mean wind speeds) as does the Wind Shear Analysis window, rather than the mean of monthly means for each measurement height.
  • Added multiple file type filters for File > Open window.
  • Added buttons to the Date/Time Anomalies window to jump to next or previous anomaly.
  • Changed the Wind Power Class window to display the mean of monthly means of WPD at each measurement height.
  • Fixed bug in Quality Control window where the ‘changes less than’ criteria measured the deviation from the initial value, rather than the deviation from peak to trough within the interval.
  • Fixed bug in Quality Control window causing it to fill gaps or replace segments in the entire date range, rather than only in the selected date range.
  • Fixed bug in Export Data window causing WindSim .tws and .wws files to be truncated at 50 lines.
  • Fixed bug causing crash when creating the seasonal profile table for data sets longer than 13 years.
  • Fixed bug in data import logic preventing it from recognizing date/time information in short data files spanning New Year’s Eve.
  • Fixed bug where the height-ordered list of wind speed sensors sometimes shuffled the order of sensors that share the same measurement height. Now sensors that share the same measurement height should always appear in the same order that they appear in the data file, and in the Configure Data Set window.
Version 1.32 (October 9, 2008)
  • Improved data import logic to better detect the first line of data.
  • Improved data import logic to automatically filter speed, stdandard deviation, and gust columns in ZephIR data files.
Version 1.31 (October 8, 2008)
  • Improved data import logic to better identify data columns, particularly in ASC SoDAR and ZephIR LiDAR data files.
  • Fixed recently-introduced bug causing “Invalid argument” error message in the Wind Shear Analysis window.
Version 1.3 (October 4, 2008)
  • Fixed bug causing occasional crash when closing Quality Control window.
  • Fixed bugs in WindSim export formats and with the export preview.
  • Fixed bug in time series export code causing missing wind speed data to result in missing wind direction data as well.
  • Improved Export Data window, added WindSim export formats.
  • Improved Gap Fill setup window by adding data coverage control, ability to choose data columns and time interval.
  • Improved data import logic to better determine associations between columns.
  • Improved Turbulence Analysis window by allowing graphical or tabular display TI versus speed, direction, month, or time of day.
  • Fixed error in Turbulence Analysis window where plot showed mean TI (rather than the representative TI) versus the IEC3 turbulence classes.
  • Made Configure Data Set window resizable.
  • Fixed some bugs relating to File > New.
  • Added radio button to Modify Data Columns window to choose between modifying all time steps or just a time segment.
  • Added checkbox filters to the Document History window.
  • Added significant digits to exported time series data.
  • Added ‘force zero intercept’ checkbox to scatterplot tab.
  • Fixed bug in Delete Data window that prevented deletion of the last time step.
  • Changed daily wind shear profile graph line label from “Annual” to “All data”.
  • Improved vertical wind shear profile graph to better handle hard-to-fit profiles.
  • Fixed bug in plot properties window causing bar charts and scatterplots to disappear after editing their properties.
  • Improved error message that reports a difference in time step between master data set and file to be appended.
Version 1.23 (May 17, 2008)
  • Fixed bug (introduced in v1.22) in table code capping all bins at 1.
Version 1.22 (May 16, 2008)
  • Fixed bug (introduced in v1.21) causing crash in Turbulence Analysis window.
Version 1.21 (May 15, 2008)
  • Fixed bug with autoscaling y-axis of boxplots.
Version 1.2 (May 6, 2008)
  • Fixed bug in wind data synthesis function causing frequent spikes in synthesized wind speed data.
  • Added append overwrite options to Options window.
  • Improved how the graphs handle off-the-charts data points.
  • Removed standard deviation of wind speed column from turbulence table in turbulence analysis window.
  • Disallowed calculation of wind power density at 50m in data sets with only one measurement height.
  • Added append overwrite mode radio button to the Tools > Options window.
  • Combined Stats and Reports tabs into the new Tables tab, added several new tables, such as Environmental Summary, Directional Statistics, Statistics by Bin.
  • Improved Turbulence Analysis window to conform to IEC 61400–1 3rd Edition.
  • Improved Wind Shear Analysis window to handle any number of wind speed sensors, to allow filtering by wind speed, and to allow tabular output.
  • Improved time series export facility to give control over time segment and format.
  • Added tab file export.
  • Improved Virtual Anemometer Window to handle any number of wind speed sensors.
  • Allowed negative power law exponents.
  • Changed Time Series tab to show dual time series plots
  • Added Delete Data window.
  • Added Wind Turbine Output Tool window.
  • Added latitude, longitude, and site description.
  • Added environmental conditions to Summary tab.
  • Added ability to hide columns in the Configure Data Set window.
  • Changed automatic column color assignment to use color progressions for wind speed, wind speed standard deviation, and wind direction columns.
  • Added ability to compare normalized power curves in Compare Wind Turbines window.
  • Improved File > Append process to store and automatically apply the last-used template, rather than the template for the master data set.
  • Changed points in vertical profile graph on wind shear analysis window to show mean wind speeds concurrent for the chosen subset of anemometers, rather than concurrent for all anemometers.
  • Improved data import logic to accept French-style comma decimal delimiters.
  • Improved data import logic to accept leading spaces in date and time fields.
  • Improved data import logic to (slightly) better detect the day of the month column.
  • Added ability to read NRG’s .a07 files.
  • Added Fuhrlander and AWE turbines to the wind turbine library.
  • Fixed bug in Wind Turbine Output window where it used the default .wtp file name regardless of what you entered in the File / Save As window.
  • Added license status to splash window.
  • Improved ability to import irregularly-spaced time series data.
Version 1.12 (May 18, 2007)
  • Fixed bug causing too few decimal places in data files exported from graphs.
Version 1.11 (April 12, 2007)
  • Fixed bug in virtual anemometer code that caused occasional crashes in the Virtual Anemometer and Quality Control windows.
Version 1.1 (March 12, 2007)
  • Improved algorithm that calculated the wind power density at 50m.
  • Improved remove template process to allow it to search the header of SDR files after template removal.
  • Added filtering capability to scatterplot tab.
  • Improved wind shear logic to allow smaller values of surface roughness.
  • Fixed text rotation bug in metafiles.
  • Improved wind rose, added default wind rose style and sectors to Preferences.
  • Changed wind shear calculation to consider only those time steps in which all anemometers contain data.
  • Added vertical profile graph to Wind Shear Analysis window.
  • Added list of anemometers to Wind Shear Analysis window.
  • Changed merge process to not overwrite existing data with gaps.
  • Added logic to read metadata in data files written by NRG’s SDR logger.
  • Added necessary recalculation upon synthesizing virtual anemometer data.
  • Added necessary recalculation upon closing the Quality Control window.
  • Fixed bug in plot y-axis scaling in gap fill preview window.
  • Fixed bug causing crash after making certain changes in the Configure Data Set window.
  • Added the ability to save as a .windog file.
  • Added the ability to append data with File / Import.
  • Added the ability to import .RWD files.
  • Added the ability to add the virtual anemometer or wind turbine output time series to the data set as a calculated column.
  • Improved Wind Shear Analysis window to allow year, month, and direction sector filtering.
  • Completely overhauled the Quality Control window, allowing removal and replacement of data segments.
  • Renamed the Identify Columns window the Configure Data Set window and split it into two tabs: Columns and Other.
  • Replaced the column type radio buttons with a icon-enabled drop-down box on the Configure Data Set window.
  • Allowed templates to be saved, loaded, and removed in the Configure Data Set window.
  • Added toolbar buttons for many windows and added icons to menus.
  • Added the Tower Shading Analysis window
  • Replaced number of months, days, and time steps with data set duration on Summary and Stats pages of main window.
  • Improved data import logic to search for day of month in two stages, with the second using a lower standard.
Version 1.07 (July 11, 2006)
  • Improved screen refresh during file open process.
Version 1.06 (June 20, 2006)
  • Made watermarks appear in all graphs when exported.
  • Fixed bug in monthly and annual reports so an empty month/year now shows an average of zero rather than DA_GAP.
  • Added maximize box to turbine compare window.
  • Fixed minor math error in downsample algorithm that caused calculations to be slightly incorrect.
  • Added third wind rose drawing style: outlined pie slices.
Version 1.05 (May 22, 2006)
  • Improved file import logic to better detect year column.
  • Based serial number on install or renewal date, so it changes upon renewal meaning renewal code works only once.
  • Added direction sector filtering to the Turbulence Analysis window.
  • Introduced zoom-to-interval capability to time series graphs.
  • Improved time series graph scroll bar to show visible fraction.
  • Allowed manual override of graph colors and axis scales.
  • Added the ability to create monthly statistics and annual statistics reports for wind direction columns.
  • Improved the Time Series window to optionally display daily/monthly/annual averages, including vector averages of wind direction data.
  • Improved Turbulence Analysis window, adding tabular display and CTI.
  • Improved file reading logic to read elevation and calm threshold from data file.
  • Improved file reading logic to better identify the year column.
  • Improved file reading logic to better identify the time column.
  • Improved file reading logic to accept more blanks.
  • Added ability to specify whether the time stamps in an imported data file refer to the beginning, middle, or end of the time step.
  • Added virtual anemometer windows.
  • Added turbine output window.
  • Added ability to select which columns get exported.
  • Added ability to select data interval when exporting data.
Version 1.04 (January 13, 2006)
  • Fixed bug in CWindDataColumnID relating to the sort order of wind speed sensors, which was causing a crash in the Quality Control window.
  • Made the Quality Control window resizeable.
  • Added “keep y-axis scale consistent” checkbox to the Quality Control window.
Version 1.03 (January 4, 2006)
  • Added Turbulence Analysis window.
  • Minor improvement to file reading logic.
  • Minor improvement to Identify Columns window.
Version 1.02 (December 8, 2005)
  • Added year and month drop-down boxes to Wind Rose, Profile, PDF, CDF, and Scatterplot pages.
  • Moved DMap page to after Scatterplot in the property sheet.
  • Stripped down CDataArray to reduce memory requirements and up-front statistical processing.
  • Added new type of wind rose: total by direction.
  • Allowed data export from wind roses.
  • Changed to scan whole file to determine number of columns.
  • Added automatic detection of height-above-ground units.
  • Improved CDataArray::ExtractSubset()
Version 1.01 (October 19, 2005)
  • Modified the numbering of graph axes to solve problems with logarithmic graphs.
  • Added welcome window, which appears the first time you run the program.
  • Fixed bug in Wind Shear Analysis window where DMap always used 1-hour time step regardless of the actual time step.
Version 1.0 (September 26, 2005)
  • Intial release.